Computers, Development Boards & Shields
Educational & Robotics Kits
Electronic Sensors
Motors & Controllers
Communication & Display
Electronic Components
Soldering & Lab Tools

0
Versalino Won’t Work with new ATMEGA328

I messed up a Versalino and a Arduino UNO when I tried hooking them up to a Roomba. (Don’t think I’ll try that again). Anyway, I just bought two ATMEGA328-PU with Arduino Bootloader – Uno chips from you to replace the ones on the boards. I was careful to place them right on the boards, and tried to download and run the Arduino Basic Blink sketch. I keep getting “avrdude: stk500-getsync ():not in sync:resp:0x00”. Is there something else wrong with the boards, are the new chips faulty? How would I find out what the problem is? (i.e. is there a way to test the chips?)

2 Answers

0

Gotcha, there is a chance that you damaged more then just the chips by connecting them to the Roomba in the wrong way (ie power mis-wiring). On the Arduino Uno there is a good chance that damaged the USB chip, and on the Versalino you could have similar problems if you had the FTDI plugged in at the same time.

For the Versalino try pressing the reset button 3 or so times after hitting the upload button to try and get it manually into program mode, and on the Arduino try the following guide for fixing the USB chip on the Arduino Uno https://www.virtuabotix.com/how-to-cure-sudden-uno-death-syndrome/

If you are still having trouble let me know and I will be happy to troubleshoot the problem further.

0

You might find the answer here.

http://forum.arduino.cc/index.php?topic=28223.0

Your Answer

No comments yet.

Leave a Reply