Computers, Development Boards & Shields
Educational & Robotics Kits
Electronic Sensors
Motors & Controllers
Communication & Display
Electronic Components
Soldering & Lab Tools

0
BT2S Bluetooth Slave Not Responding

I just received your BT2S Slave Bluetooth To Serial board.

I have connected it with the included cable to an Arduino Uno per the connection diagram included with the board.

When I try to upload the Arduino sketch from your BT2S Slave Configuration web page I get the following error:

avrdude: stk500_getsync(): not in sync: resp=0x00

I get this error even if I try to upload the simple Blink sketch included with the Arduino. If I remove the BT2S board, I can then upload the configuration sketch (or the blink sketch). So the Uno is working properly.

If I try to connect with the Android BlueTerm app, I get “Unable To Connect Device”

I then removed the BT2S, uploaded the configuration sketch, powered the Uno down, connected the BT2S and powered up the Uno. This got the blinking red light on the BT2S to blink a few times, but nothing else happened. I was still unable to connect with BlueTerm. The green light on the BT2S never came on.

I am running Windows 7 Ultimate 64 bit for the Arduino editor and it has worked properly before. I restarted Windows and reset the Uno multiple times. But, so far, nothing has worked.

Any help will be greatly appreciated!

David

1 Answer

0
accepted
David,
When programming the Arduino make sure that the BT2S is not connected since its transmit and receive lines interfere with the programming process.
Once you put the configuration program on the board then connect up the BT2S (if you are doing this with a standard Arduino I would change the status LED to 13 to use the onboard LED).
If you just get slow blinks on pin 13 then try and switch the transmit and receive pin (for configuring the BT2S you may have to reverse the TX and RX pins).
If you still can’t get it working then let me know, so we can trouble shoot in more detail.
Respectfully,
Joseph Dattilo

Your Answer

No comments yet.

Leave a Reply