Computers, Development Boards & Shields
Educational & Robotics Kits
Electronic Sensors
Motors & Controllers
Communication & Display
Electronic Components
Soldering & Lab Tools

1
Barduino plus – Programmed once, now can’t use

I ordered the Barduino Plus from Amazon a while ago. Only recently was I able to actually put the thing together. I had a space FTDI cable, so I used that to provide power, gnd, rx and tx.

When I tried to program the barduino with the basic blink program (slightly different timing on the delays from the blink already installed) I got an error message. I looked it up, and saw something about having tx/rx swapped. So I flipped the cables, and it worked perfectly, I uploaded the blink command, and all was well.

 

Then I tried to modify the blink, just to try some basic programming from memory (making it an SOS vs. basic blink), but when I try to upload it now, I get error messages.

I have unplugged/plugged it back in, I have grounded the reset pin, but it just blinks. Its set for Duemilanove with ATmega328, and I have made sure the COM is correctly selected each time I plugged it back in.

The odder part is that I only ever get one error message, but its almost never the same twice. I just tried to upload the basic blink program again and got:

avrdude: stk500_getsync(): not in sync: resp=0x30

hit upload again and got:

avrdude: stk500_getsync(): not in sync: resp=0x00

then again and got:

avrdude: stk500_getsync(): not in sync: resp=0x3e

not three more times and it went back to the original 0x30.

 

Not sure what to do, or if something may have been damaged.

 

1 Answer

0

So, I checked out some other forums, and did find something that seemed to work – it requires me to unground the reset pin just as the IDE is about to upload (just after it finishes compiling). I did it twice and it seems to work just fine.

Any way to fix this so I don’t have to unground the pin just before the upload?

 

Also, the website seems to have me listed as a blank entity. My username should have been Martinwuff. đŸ™‚

 

Your Answer

No comments yet.

Leave a Reply