Computers, Development Boards & Shields
Educational & Robotics Kits
Electronic Sensors
Motors & Controllers
Communication & Display
Electronic Components
Soldering & Lab Tools

0
Arduino Uno doesn’t work except when I change out the ATMEGA328 chip

i got same avrdude: getsync not in sync 0x0000 kind of error while loading a simple blink led code…b4 few minutes my Arduino Uno Rev 3 board was working nd loading properly….

Now i read all above chats and followed every idea there…i used FLIP to reupload hex by shorting reset nd gnd pins near usb….even after doing that i still get same error…i hva another uno Rev3 board in working condition….so i removed atmega328 ic from problem board nd fixed it in working board….then it loads perfectly…so i dont have problem with bootloader in the 328 ic….i reuploaded atmega16u2 hex file using FLIP successfully…what cud be possible problem??i m not so rich to afford a loss of my money….pls guide me….

1 Answer

0
accepted

Based on your description you already tried this guide https://www.virtuabotix.com/how-to-cure-sudden-uno-death-syndrome/. Since your Arduino Uno worked when you exchanged the ATMEGA chip your Arduino Uno the most likely reason for your problem is that you somehow damaged your ATMEG328 chip.

Usually damage to your ATMEGA328 chip is caused by driving too much current on your device. Luckily we have the best price on replacement Arduino Uno Bootloaded ATMEGA328P-PU chips so you should be able to get your board running with no issue by picking one of them up. https://www.virtuabotix.com/productpage/0609224531750/
I hope that helps you solve your problems!

Your Answer

No comments yet.

Leave a Reply